Print Page | Close Window

Compatible with P3D v4.5?

Printed From: Ultimate Traffic Forums
Category: Ultimate Traffic Live
Forum Name: General Discussion - Non Support Topics Only
Forum Description: For general information and screen captures of Ultimate Traffic Live - Not for support.
URL: http://ultimatetraffic.flight1.net/forums/forum_posts.asp?TID=17908
Printed Date: August-24-2019 at 10:28am
Software Version: Web Wiz Forums 11.10 - http://www.webwizforums.com


Topic: Compatible with P3D v4.5?
Posted By: rogiermaas
Subject: Compatible with P3D v4.5?
Date Posted: May-18-2019 at 4:36pm
Hi,

I have just moved from FSX and all the products I bought for hundreds and hundreds of Euros to P3D v4.5. I am convinced this is the product I want for my v4.5 version of P3D but I want to be SURE UT Live is compatible with v4.5. All I see is that it is compatible with P3D4. I'm not sure that means it is compatible with all versions within the v4 branche. Could somebody confirm this product is compatible? Thanks!

Rogier



Replies:
Posted By: pgde
Date Posted: May-19-2019 at 11:22am
Yes it is.

-------------
Gigabyte Z97X-UD5H-BK,Blk Ed MB;Intel I7-4790K CPU;16 Gb G.Skill RAM (F3-2400); Win7 Pro; 2 - Samsung 1Tb SSDs; Toshiba 3Tb hard drive; Gigabyte Aorus 1080ti Extreme 11Gb VRAM.


Posted By: rogiermaas
Date Posted: May-19-2019 at 11:33am
* clicking on ‘Add to Cart’

Thanks!



Print Page | Close Window

Forum Software by Web Wiz Forums® version 11.10 - http://www.webwizforums.com
Copyright ©2001-2017 Web Wiz Ltd. - https://www.webwiz.net