Print Page | Close Window

UTL_FP says aircraft.txt file is missing

Printed From: Ultimate Traffic Forums
Category: Ultimate Traffic Live
Forum Name: General Discussion - Non Support Topics Only
Forum Description: For general information and screen captures of Ultimate Traffic Live - Not for support.
URL: http://ultimatetraffic.flight1.net/forums/forum_posts.asp?TID=18426
Printed Date: September-18-2020 at 1:35pm
Software Version: Web Wiz Forums 11.10 - http://www.webwizforums.com


Topic: UTL_FP says aircraft.txt file is missing
Posted By: Simwin7
Subject: UTL_FP says aircraft.txt file is missing
Date Posted: July-20-2020 at 6:49pm
I've been trying to convert some standard .txt flightplans using the UTL_FP ulitity without success.

When I load a flightplans.txt file in the utility, a popup window appears stating that the expected associated aircraft.txt file is missing.

But the aircraft file is not missing. It is in the same folder with the flightplans file and it is naming structure matches the flightplans file. 

Is there a specific folder location that we need to use with this tool in order for it to see the files?

I've tried everything I can think of and the error persists.

Can someone give me a hint?



Replies:
Posted By: ScottecLEMD
Date Posted: July-21-2020 at 3:22am
In reality all you need to do is unzip the flightplan zip file which should contain the flightplan, aircraft and airports txt files. Post a screen shot of the unzipped contents so that I can see what you have.

-------------
Ken Brattey


Posted By: Simwin7
Date Posted: July-21-2020 at 3:43pm
So you are saying I can open the zip file directly with UTL_FP? 

I do have the zip file with the flightplan, aircraft, and airport txt tiles. 

I had unzipped them into a folder containing the 3 txt files. AIFP reads them just fine so I know they are good and without errors.


Posted By: ScottecLEMD
Date Posted: July-21-2020 at 4:21pm
No you can't use the UT FP tool to unzip. Sounds like you are doing everything correctly. Which airline is it? Maybe there is a localised problem with the file.

-------------
Ken Brattey


Posted By: Simwin7
Date Posted: July-21-2020 at 4:44pm
It's WestAir, a FedEx C208B feeder, in this example. Here is the folder containing the unzipped files. The files read fine in AIFP:


And this is the error UTL_FP throws. It does this with ANY unzipped Flightplans package I give it. The aircraft.txt, flightplans.txt and airports.txt files have matching names and live in the same folder each time I try. I even tried changing all characters lower case. I've tried different drives in my system. I'm running as admin in Windows10. Could it be that this is a 32bit program?:



Posted By: ScottecLEMD
Date Posted: July-22-2020 at 2:09am
Can you give me the link to download the plans?


I also use Windows 10 64bit without any issues and I download most if not all of my flightplans from AIG.

It looks as though maybe the aircraft.txt file has no entries??

However, if it all works in AIFP then all I can suggest is to try saving them as a new file set in AIFP and then try to install that one.


-------------
Ken Brattey


Posted By: Simwin7
Date Posted: July-22-2020 at 1:22pm
I was advised by another member that there is a known folder naming bug with UTL_FP.

The folder containing the text files must NOT have the word "flightplans" in it.

I had the files unzipped into a folder named "Flightplans" for my own purposes of organization. Doh! 

Everything reads great now. Thanks for your help Ken and member "dodo"!


Posted By: ScottecLEMD
Date Posted: July-22-2020 at 3:18pm
I learned something new as well then 😀 Glad you are up running.

-------------
Ken Brattey



Print Page | Close Window

Forum Software by Web Wiz Forums® version 11.10 - http://www.webwizforums.com
Copyright ©2001-2017 Web Wiz Ltd. - https://www.webwiz.net